Why won't Biomeme Cloud load on my computer?

To ensure our customers' data always remains safe, we require browsers which support TLS1.2 or higher to access cloud.biomeme.com. Though rare, if you are using an old internet browser, please switch to a browser such as Chrome, Firefox, or Safari to access Biomeme Cloud. Please contact us at support@biomeme.com if you have any questions or issues. 

For more information, please refer to our Biomeme Software Security Statement.